1.составить алгоритм и программу нахождения суммы следующих чисел: 1, 12, 35, 70, 117, ..532. 2.-х- 3.написать программу, которая вводит с клавиатуры число от 0 до 999999 (использовать переменные типа longint) и выдает на экран дисплея сумму цифр этого числа. 4.составить алгоритм и программу сортировки массива символов латинского алфавита. 5.составить алгоритм и программу сортировки массива по убыванию методом пузырьков с перемещнием минимального элемента. хотя бы с одним

MadamHlebushek11 MadamHlebushek11    2   31.07.2019 09:50    2

Ответы
DANIKom DANIKom  28.09.2020 14:17
3. pascal
var s, a: integer;
g:longint;
begin
s:=0;
readln(g);
while g > 0 do
begin
a:=g mod 10;
g:=g div 10;
s:=s+a;
end;
writeln(s)
end. 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика