1. построить и записать в виде программы алгоритм вычисления суммы квадратов десяти произвольных чисел, вводимых с клавиатуры в процессе выполнения программы. 2. вводятся 15 чисел. определить, сколько среди целых чисел. 3. вывести все четные числа начиная с числа n и до числа m. числа n и m задает пользователь. 4. составить программу, печатающую все делители целого числа в порядке возрастания

buschckovaanas buschckovaanas    3   28.06.2019 10:30    6

Ответы
АААННЯЯЯ111 АААННЯЯЯ111  22.07.2020 17:20
На паскале.
1)
var i, n, sum : integer;
begin
sum := 0;
for i := 1 to 10 do
begin
readln(n);
sum := sum + n * n;
end;
writeln(sum);
end.
2) 
var i, sum : integer;
n : real;
begin
sum := 0;
for i := 1 to 15 do
begin
readln(n);
if n = trunc(n) then sum := sum + 1;
end;
writeln(sum);
end.
3) var n, m, i : integer;
begin
readln(n, m);
for i := n to m do
if i mod 2 = 0 then writeln(i);
end.
4) var n, i : integer;
begin
readln(n);
for i := 1 to n do
if n mod i = 0 then writeln(i);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика