1 переведите формулу на язык паскаль. #2 составить программу вычисления функции у(х); значения переменных задайте самостоятельно с оператора ввода. в отчет включить текст программы, реакцию эвм.
y := (a * x + 2 * b * x * x) * Abs(Cos(x * x)) / (Pi * Exp(x));
y := (a * Ln(b * x)) ** (1 / 3) / (1 + Sqr(Sin(a * x)));
y := (Abs(Sin(x ** 3)) + a) * Exp(a) / (b * b + c * c) ** (1 / 3);
#2
begin
var (a, x) := ReadReal2('Введите a и x:');
var t := x ** 3 - a;
t := Sign(t) * Abs(t) ** (1 / 3);
var y := t + Sin(x * x) / a;
Print('y =', y)
end.
Операция возведения в степень ** в PascalABC.NET определена только для неотрицательного аргумента, поскольку она выполняется с использованием логарифма. В то же время, в математике операция извлечения корней нечетной степени для отрицательного аргумента опеределена и допустима. В соответствии с этим, извлечение кубического корня в программе производится из абсолютной величины аргумента и последующим присваиванием знака этого аргумента результату. Если имеется потребность вычислять подобные корни в нескольких местах программы, имеет смысл ввести для этого собственную функцию.
===== PascalABC.NET =====
#1
y := (a * x + 2 * b * x * x) * Abs(Cos(x * x)) / (Pi * Exp(x));
y := (a * Ln(b * x)) ** (1 / 3) / (1 + Sqr(Sin(a * x)));
y := (Abs(Sin(x ** 3)) + a) * Exp(a) / (b * b + c * c) ** (1 / 3);
#2
begin
var (a, x) := ReadReal2('Введите a и x:');
var t := x ** 3 - a;
t := Sign(t) * Abs(t) ** (1 / 3);
var y := t + Sin(x * x) / a;
Print('y =', y)
end.
Операция возведения в степень ** в PascalABC.NET определена только для неотрицательного аргумента, поскольку она выполняется с использованием логарифма. В то же время, в математике операция извлечения корней нечетной степени для отрицательного аргумента опеределена и допустима. В соответствии с этим, извлечение кубического корня в программе производится из абсолютной величины аргумента и последующим присваиванием знака этого аргумента результату. Если имеется потребность вычислять подобные корни в нескольких местах программы, имеет смысл ввести для этого собственную функцию.
#include <iostream>
#include <cmath>
using namespace std;
int main()
{
double x,y,A,a,b;
cin>>a>>b>>x;
y=cos(x*x*x)*cos(x*x*x)-x/sqrt(a*a+b*b);
A=abs(pow(x,y/x)-pow(y/x,1/3));
cout<<"y="<<y<<"\nA="<<A;
return 0;
}