1. pascal. даны три точки a(x1,y1), b(x2,y2), c(x3,y3). написать программу, определяющую, которая из точек находится ближе к началу координат.

kristinaFro kristinaFro    2   22.05.2019 05:00    8

Ответы
вера731 вера731  17.06.2020 06:55

Проверено - работает на Паскаль АВС:

 

Program kovyarovsany;
var
  x1,y1,x2,y2,x3,y3:integer;
  d1,d2,d3:real;
begin
  write ('X1 = ');readln(x1);
  write ('Y1 = ');readln(y1);  
  write ('X2 = ');readln(x2);
  write ('Y2 = ');readln(y2);
  write ('X3 = ');readln(x3);
  write ('Y3 = ');readln(y3);  
  d1:=sqrt(x1*x1+y1*y1);
  d2:=sqrt(x2*x2+y2*y2);
  d3:=sqrt(x3*x3+y3*y3);
  if (d1=d2) and (d1=d3) then
      writeln ('Все три точки на одинаковом расстоянии от начала координат ')
    else
    if (d1=d2) and (d1<d3) then
      writeln ('Точка 1 и точка 2 на одинаковом расстоянии от начала координат ')
    else
      if (d2=d3) and (d2<d1) then
        writeln ('Точка 2 и точка 3 на одинаковом расстоянии от начала координат ')
      else
        if (d1=d3) and (d1<d2) then
          writeln ('Точка 1 и точка 3 на одинаковом расстоянии от начала координат ')
        else
          if (d1<d2) and (d1<d3) then
             writeln ('Точка 1 ближе всех')
          else
            if (d2<d1) and (d2<d3) then
              writeln ('Точка 2 ближе всех')
            else
               writeln ('Точка 3 ближе всех');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика