1) одномерный массив из 6 элементов заполнить случайным образом числами от 5 до 17. поменять местами 5-ый и 7-ой элементы массива, а 4-ый элемент увеличить в 3 раза. вывести на экран монитора первоначальный и преобразованный массивы в строчку. , составить программу массива.

Алексей712 Алексей712    3   16.06.2019 20:40    1

Ответы
рома1325 рома1325  13.07.2020 17:26
В задании ошибка: Одномерный массив из 6 элементовПоменять местами 5-ый и 7-ой элементы 



#include <iostream>
#include <stdlib.h>      
#include <time.h>    

void Swap(int & a, int & b) {int t = a; a = b; b = t;}

int main(){
    srand(time(NULL));

    const int n = 6;
    int f[n], s[n];

    for (unsigned int i = 0; i < n; ++i) {
        f[i] = rand() % 12 + 5;
        s[i] = f[i];
    }

    // Меняем 5 и 6 элементы местами
    Swap(s[4], s[5]);
    s[3] *= 3;

    std::cout << "First: ";
    for (unsigned int i = 0; i < n; ++i) {
        std::cout << f[i] << ", ";
    }
    std::cout << std::endl;

    std::cout << "Second: ";
    for (unsigned int i = 0; i < n; ++i) {
        std::cout << s[i] << ", ";
    }
    std::cout << std::endl;
    return 0;
}
  
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика