1.нужно составить программу перевода градусов в интервале 15-30 шкалы цельсия на градусы фаренгейта. формула преобразования f=c*1.8+32, здесь с – градусы цельсия; f – градусы фаренгейта. 2. набирается последовательность слов, в конце которой нажимается клавиша enter. нужно написать программу, которая подсчитывает количество введённых символов и сколько раз встречается буква т в тексте. 9 класс. язык програмирования паскаль

POLTIT1 POLTIT1    1   18.03.2019 05:00    4

Ответы
refddk refddk  25.05.2020 22:28

Program Pr1;
uses crt;
var f,c:real;
begin
clrscr;
c:=15;
while c<=30 do begin
f:=c*1.8+32;
writeln(c,'-Цельсия; Фаренгейт - ',f);
c:=c+1;
end;
end.

2)

Program Pr1;
uses crt;
var stroka:string;
i,v,x:integer;
Begin
clrscr;
readln(stroka);
x:=0;
v:=0;
for i:=1 to length(stroka) do begin
if stroka[i]<>' ' then v:=v+1;
if (stroka[i]='т') or (stroka[i]='Т') then x:=x+1;
end;
writeln('Количество букв- ',v,' Количество букв Т -',x);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика