1. нужно составить программу на языке программирования (язык программирования и версию необходимо обязательно указать, иначе количество за будет равно 0) : календарь жителей планеты мульти состоит из n месяцев, каждый месяц состоит ровно из 30 дней, неделя состоит из 7 дней. особо несчастливыми на планете мульти считается 13-е число месяца, если оно выпадает на пятницу. известно, что новый год на планете мульти начался в k-й по счету день недели (1-й день недели — понедельник, 2-й — вторник, 3-й — среда, … , 7-й — воскресенье). определите, сколько в этом году на планете мульти будет особо несчастливых пятниц, 13-е. программа получает на вход два натуральных числа, записанных в отдельных строках. первое число — количество месяцев в календаре планеты мульти n, не превосходящее 109. второе число — номер дня недели, на который приходится первое число первого месяца нового года, может принимать значения от 1 до 7. программа должна вывести единственное натуральное число — количество несчастливых дней в этом году. пример входных и выходных данных ввод вывод примечание 12 1 2 2 на 13-е число будут приходиться пятницы четверого и одиннадцатого месяцев.

Отличница4561 Отличница4561    3   21.06.2019 19:20    3

Ответы
ENTER717 ENTER717  02.10.2020 07:54
Язык программирования Pascal ABC
var n,k,i,j,d,c:integer;
label 1,2;
begin
1:writeln('Количество месяцев в календаре планеты Мульти:');
readln(n);
if (n>109)or(n<1) then
begin
writeln('Ошибка! Количество месяцев должно быть меньше или равно 109. Повторите ввод.');
goto 1;
end;
2:writeln('Номер дня на который приходится первое число первого месяца нового года:');
readln(k);
if (k>7)or(k<1) then
begin
writeln('Ошибка! Номер дня должен быть в диапозоне от 1 до 7. Повторите ввод.');
goto 2;
end;
d:=k;
for i:=1 to n do
begin
for j:=1+(k-1) to 30 do
begin
if (d=5)and(j=13) then c:=c+1;
d:=d+1;
if d>7 then d:=1;
end;
k:=1;
end;
writeln('Количество несчастливых дней в этом году: ',c);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика