1. необходимо задать массив размерностью 5, заполнить массив случайными числами в интервале [-1,1] и вывести элементы на экран: определить три позиции для вывода каждого элемента.
2. составить программу, которая формирует массив из семи случайных вещественных чисел, принадлежащих промежутку [3; 4). и выводит пять первых чисел массива с двумя десятичными цифрами в столбец шириной 8 знаков.
3. заполните пропуски в программе ввода и вывода 10 целочисленных элементов массива, заданных случайным образом на промежутке [20; 40]:
var a: array[ of integer;
i: integer;
begin
for i: =1 to __ do begin
a[i] : = + ;
;
end;
end.
4. составьте программу для ввода в массив 7 целых чисел с клавиатуры и вывода этих чисел в обратном порядке.

Azazel500 Azazel500    1   13.10.2019 10:49    28

Ответы
Dan2707 Dan2707  27.12.2023 15:58
Хорошо, дайте мне немного времени, чтобы подробно ответить на каждый из вопросов.

1. Для задания массива размерностью 5 и заполнения его случайными числами в интервале [-1,1] можно использовать следующий код на языке программирования Pascal:

```pascal
var
a: array[1..5] of real;
i: integer;

begin
Randomize; // Инициализация генератора случайных чисел

for i := 1 to 5 do
begin
a[i] := Random * 2 - 1; // Генерация случайного числа в интервале [-1,1]
end;

for i := 1 to 5 do
begin
WriteLn('Элемент ', i, ': ', a[i]:0:2); // Вывод элемента массива с двумя десятичными цифрами
end;
end.
```

В этом коде мы создаем массив `a` размерностью 5 и используем цикл `for` для заполнения его случайными числами. Затем мы снова используем цикл `for` для вывода элементов массива на экран. Обратите внимание, что мы используем форматирование `:0:2` для вывода чисел с двумя десятичными цифрами.

2. Для создания массива из семи случайных вещественных чисел, принадлежащих промежутку [3; 4), и вывода пяти первых чисел с двумя десятичными цифрами в столбец шириной 8 знаков, можно использовать следующий код на языке Pascal:

```pascal
var
a: array[1..7] of real;
i: integer;

begin
Randomize; // Инициализация генератора случайных чисел

for i := 1 to 7 do
begin
a[i] := Random + 3; // Генерация случайного числа в промежутке [3;4)
end;

for i := 1 to 5 do
begin
WriteLn(a[i]:8:2); // Вывод пяти первых чисел массива с двумя десятичными цифрами в столбец шириной 8 знаков
end;
end.
```

В этом коде мы создаем массив `a` размерностью 7 и используем цикл `for` для заполнения его случайными числами в промежутке [3; 4). Затем мы снова используем цикл `for` для вывода пяти первых чисел массива на экран с помощью форматирования `:8:2` для выделения места для двух десятичных цифр в столбце шириной 8 знаков.

3. Для заполнения пропусков в программе ввода и вывода 10 целочисленных элементов массива, заданных случайным образом на промежутке [20; 40], можно использовать следующий код на языке Pascal:

```pascal
var
a: array[1..10] of integer;
i: integer;

begin
Randomize; // Инициализация генератора случайных чисел

for i := 1 to 10 do
begin
a[i] := Random(21) + 20; // Генерация случайного числа из промежутка [20;40]
end;

for i := 1 to 10 do
begin
WriteLn('Элемент ', i, ': ', a[i]); // Вывод элемента массива
end;
end.
```

В этом коде мы создаем массив `a` размерностью 10 и используем цикл `for` для заполнения его случайными числами на промежутке [20; 40]. Затем мы снова используем цикл `for` для вывода элементов массива на экран.

4. Для ввода в массив 7 целых чисел с клавиатуры и вывода этих чисел в обратном порядке можно использовать следующий код на языке Pascal:

```pascal
var
a: array[1..7] of integer;
i: integer;

begin
for i := 1 to 7 do
begin
Write('Введите число ', i, ': ');
ReadLn(a[i]); // Ввод числа с клавиатуры
end;

WriteLn('Введенные числа в обратном порядке:');
for i := 7 downto 1 do
begin
WriteLn(a[i]); // Вывод чисел массива в обратном порядке
end;
end.
```

В этом коде мы создаем массив `a` размерностью 7 и используем цикл `for` для ввода семи чисел с клавиатуры. Затем мы используем цикл `for` с оператором `downto` для вывода чисел массива в обратном порядке.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика