1. найдите наибольший элемент одномерного массива, состоящего из 12 элементов. элементы датчиком случайных чисел из интервала [-25,31] 2. массив а вводится с клавиатуры. найдите произведение отрицательных элементов с выводом на экран массива а

tanya596 tanya596    2   21.07.2019 21:30    2

Ответы
wjp39391 wjp39391  31.07.2020 17:50
1. в C++

#include <iostream>
#include <ctime>
int main()
{
    using namespace std;
    int ar[12];
    srand(time(0));
    for (int i = 0; i < 12; i++)
        ar[i] = -25 + rand() % 57;

    int temp = ar[0];
    for (int i = 0; i < 12; i++)
        if (ar[i] > temp)
            temp = ar[i];

    for (int i = 0; i < 12; i++)
        cout << ar[i] << "  ";

    cout << endl;
    cout << "Max: " << temp;
    cout << endl;
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика