1) напишите программу, вычисляющую значение функцию y=n(x+3x)^4-12xn+2n, для х и n введённых с клавиатуры. вычисление значения функции вынесите в отдельную процедуру. 2) напишите программу вычисляющую количество пар чисел, сумма которых четна 6 пар чисел вводится с клавиатуры ввода выберите сами) ! )

Zoi568 Zoi568    1   14.09.2019 21:00    4

Ответы
Irby Irby  07.10.2020 15:15
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!

procedure DimDimoch(x:real; n:integer; var r:real);
begin
  r:=n*Sqr(Sqr((x+3*x)))-12*x*n+2*n
end;

begin
  var x:real;
  var n:integer;
  Write('Введите x и n: '); Read(x,n);
  var r:real;
  DimDimoch(x,n,r);
  Writeln('Значение функции ',r)
end.

Пример
Введите x и n: -1.23 4
Значение функции 2410.83920384

begin
  Writeln('Введите 6 пар целых чисел');
  var k:=0;
  loop 6 do begin
    var (a,b):=ReadInteger2;
    if (a+b).IsEven then k+=1
    end;
  Writeln('Число пар с четной суммой: ',k)
end.

Пример
Введите 6 пар целых чисел
15 23
19 -7
5 0
4 11
132 63
444 12
Число пар с четной суммой: 3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика