1.напишите программу, вычисляющую значение функции: y =5 при x< 2 2 при x=2 10 при x> 2(программа паскаль) 2.дан условный оператор: if a< 7 then c: =10 else if a> 7 then c: =2 else c: =5 какое значение имеет переменная а, если в результате выполнения условного оператора переменной с присваивается значение 5? (программа паскаль)

1483983829 1483983829    2   24.08.2019 17:30    4

Ответы
goroh4 goroh4  26.08.2020 09:28
Var
Y,X:real;
Begin
Write('X = ');ReadLn(X);
if X<2 then Y:=5
else if X=2 then Y:=2
     else Y:=10;
WriteLn('Y = ',Y);
End.

2)

c = 5, когда не выполняется оба условия, то есть:

If a<7 then c:=10        // a>=7
else if a>7 then c:=2    // a>7
else c:=5

Переменная a может иметь любое значение больше семи.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика