1.напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 0. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). 2.что будет на экране после выполнения программы var i, s,k: integer; begin .. s : = 0; for i : = 0 to 10 do s : = s-i+5; writeln(s); end.

томкавеликая томкавеликая    3   07.09.2019 20:30    3

Ответы
анютка6780 анютка6780  06.10.2020 23:37
1) (если последовательность не пустая, т.е есть хотя бы 1 число <> 0)
var x,k:integer;
begin
k:=0;
repeat
readln(x);
if (x mod 10=0) and (x mod 3=0) then inc(k);
until x=0;
writeln(k-1);
end.

2) 0

s=0-0+5-1+5-2+5-3+5-4+5-5+5-6+5-7+5-8+5-9+5-10+5=0
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика