1)напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающихся 0 или 1. программа получает на вход целые числа от -3000 до 3000. 2)напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3. нужно сегодня! 66 !

sasha11225 sasha11225    2   31.03.2019 23:00    2

Ответы
DreamEvilDead DreamEvilDead  28.05.2020 02:10

 

var b,i :integer;

a:array[1..10] of integer;

begin

for i:=1 to 10 do

readln(a[i]);

for i:=1 to 10 do begin

if (a[i] mod 5=0) or (a[i] mod 7 =0) or (a[i] div 10=1) or (a[i] mod 10 =1) then b:=b+1;end;

writeln (b);

end.

 

 

var b,c,i :integer

a:array[1..10] of integer;

begin

for i:=1 to 10 do

readln(a[i]);

for i:=1 to 10 do begin

if (a[i] mod 3=0) and (a[i] mod 2 = 0) and (a[i] div 10<>0)and (a[i] div 100=0) then begin b:=b+a[i];c:=c+1;end;end;

writeln(b/c);

end;

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы