1) напишите программу, которая спрашивает целые числа а и b и выводит на экран количество чётных и нечётных чисел в диапазоне от а до b 2)напишите программу, которая спрашивает целое число n , целые числа а и b,и выводит на экран n случайных чисел от а до b

arinakirkot arinakirkot    2   09.09.2019 17:30    2

Ответы
jrihdevhdve jrihdevhdve  07.10.2020 03:42
// PascalABC.NET 3.3, сборка 1561 от 02.11.2017
// Внимание! Если программа не работает, обновите версию!

1)

begin
  var (a,b):=ReadInteger2('Введите границы диапазона:');
  var Всего:=b-a+1; // количество целых чисел в диапазоне
  var Четных,Нечетных:integer;
  if a.IsOdd then begin Четных:=Всего div 2; Нечетных:=Всего-Четных end
  else begin Нечетных:=Всего div 2; Четных:=Всего-Нечетных end; // четное a
  Writeln('Нечетных- ',Нечетных,', четных- ',Четных)
end.

Пример
Введите границы диапазона: -4 4
Нечетных- 4, четных- 5

2)

begin
  var (n,a,b):=ReadInteger3('Введите n,a,b:');
  SeqRandom(n,a,b).Println
end.

Пример
Введите n,a,b: 15 -10 35
19 33 -10 4 5 -10 10 21 17 21 14 21 24 23 18
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика