1)напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр(например, 222) 2)напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221) паскаль

lopkin lopkin    3   18.08.2019 20:30    50

Ответы
Piralta11 Piralta11  05.10.2020 03:31
1)
#include <iostream>
#include <math.h>

using namespace std;

int main() {
 int a;
 cin >> a;
 int d = a%10;
 string s = "yes";
 while(abs(a) > 0) {
   if(a%10 != d) {
     s = "no";
     break;
   }
   a/=10;
  }
  cout << s << endl;
}
2)
#include <iostream>
#include <math.h>

using namespace std;

int main() {
 int a;
 cin >> a;
 int d = a%10;
 a/=10;
 string s = "no";
 while(abs(a) > 0) {
  if(a%10 == d) {
    s = "yes";
    break;
  }
  d = a%10;
  a/=10;
  }
  cout << s << endl;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика