1. напишите программу, которая определяет, верно ли, что введённое число -– трёхзначное. 2. напишите программу, которая вводит с клавиатуры номер месяца и определяет, сколько дней в этом месяце. при вводе неверного номера месяца должно быть выведено сообщение об ошибке. считается, что год невисокосный. 3. напишите программу, которая вводит с клавиатуры номер месяца и день, и определяет, сколько дней осталось до нового года. при вводе неверных данных должно быть выведено сообщение об ошибке. считается, что год невисокосный. 4. напишите программу, которая вводит номер месяца и выводит название времени года на языке. при вводе неверного номера месяца должно быть выведено слово 'no'. на python

Rawree258 Rawree258    3   05.10.2019 04:00    51

Ответы
Шмигельська Шмигельська  09.10.2020 20:59

1

x = int(input())

if(x >= 100 and x <= 999):

   print("Число трехзначное")

else: print("Число НЕ трехзначное")

2

month = int(input())

if(month >= 1 and month <= 12):

   if(month == 1 or month == 3 or month == 5 or month == 7 or month == 8

      or month == 10 or month == 12):

       print(31)

   elif(month == 2):

       print(28)

   else: print(30)

else: print("Неверно введеный номер месяца!")

3

from sys import exit

month = int(input("Месяц: "))

day = int(input("День: "))

remainder = 0

if(month >= 1 and month <= 12):

   if(month == 1 or month == 3 or month == 5 or

      month == 7 or month == 8 or month == 10 or month == 12):

       if(day >= 1 and day <= 31):

           pass

       else: print("Неверно введены дни месяца!"); exit();

   elif(month == 2):

       if(day >= 1 and day <= 28):

           pass

       else: print("Неверно введены дни месяца!"); exit();

   else:

       if(day >= 1 and day <= 30):

           pass

       else:

           print("Неверно введены дни месяца!"); exit();

       

   for i in range(1, month+1):

       if(i == 1 or i == 3 or i == 5 or i == 7 or i == 8

          or i == 10 or i == 12):

           remainder += 31

       elif(i == 2):

           remainder += 28

       else: remainder += 30

   remainder += day

   print("До нового года осталось: " + str(365 - remainder))

else: print("Неверно введеный номер месяца!")

4

month = int(input())

if(month >= 1 and month <= 12):

   if(month == 12 or month == 1 or month == 2):

       print("Winter!")

   elif(month == 3 or month == 4 or month == 5):

       print("Spring!")

   elif(month == 6 or month == 7 or month == 8):

       print("Summer!")

   elif(month == 9 or month == 10 or month == 11):

       print("Autumn!")

else: print("Wrong number of month!")

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика