1. напишите программу, которая находит максимальный и минимальный из чётных положи- тельных элементов массива. если в массиве нет чётных положительных элементов, нужно вывести сообщение об этом. 2. введите массив с клавиатуры и найдите (за один проход) количество элементов, имеющих максимальное значение. 3. найдите за один проход по массиву три его различных элемента, которые меньше всех ос- тальных («три минимума»). 4. *заполните массив случайными числами в диапазоне 10..12 и найдите длину самой длинной последовательности стоящих рядом одинаковых элементов на питоне ! )

allaaleksandro1 allaaleksandro1    2   23.09.2019 17:50    9

Ответы
мам65 мам65  08.10.2020 12:55
задача 1.
a=input().split()

f=-1

for i in range(len(a)):

    if int(a[i])>0 and int(a[i])%2==0:

        if f==-1:

            min1=int(a[i])

            max1=int(a[i])

            f=1

        elif int(a[i])>max1:

            max1=int(a[i])

        elif int(a[i])<min1:

            min1=int(a[i])

if f==-1:

    print('not solution')

else:

    print('max=',end='')

    print(max1)

    print('min=',end='')

    print(min1)

задача 2.

a=input().split()

k=0

max1=float(a[0])

for i in range(len(a)):

    if float(a[i])==max1:

        k+=1

    elif float(a[i])>max1:

        k=1

        max1=float(a[i])

print(k)

задача 3.

a=input().split()

min1=float(a[0])

min2=float(a[0])

min3=float(a[0])

for i in range(len(a)):

    if float(a[i])<min1:

        min3=min2

        min2=min1

        min1=float(a[i])

    elif float(a[i])<min2:

        min3=min2

        min2=float(a[i])

    elif float(a[i])<min3:

        min3=float(a[i])

print(min1)

print(min2)

print(min3)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика