1. напишите программу, которая генерирует 10 случайных чисел от 1 до 20,выводит числа на экран и вычисляет их сред арифм. 2. напишите прог, в которой осуществляется ввод целых чисел,до тех пор, пока не будет введен 0 и определено максимальное из введенных чисел

gilmutdinova011 gilmutdinova011    3   31.05.2019 01:20    3

Ответы
victory66 victory66  01.07.2020 11:12
Задача 1
Var i,sum:integer;
      mas:array [1..10] of integer;
Begin 
  for i:=1 to 10 do begin         
     mas[i]:=random(20);           
      write(' ',mas[i]);           
     sum:=sum+mas[i];                   
                         end; 
writeln; 
   write('Среднее арифметическое этих чисел = ',sum/10);
End.

Задача 2 
Var i,max:integer;
Begin 
readln(i); 
    while (i<>0) do begin   
       if (i>max) then max:=i;   
          readln(i);     
                       end; 
  Writeln('Максимальное число: ',max);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика