1)напишите программу формирования массива размеров 5 х 5 с датчика случайных чисел.замените в нем все четные значения элементов суммой индексов элементов главной диагонали.выведите на экран исходный и измененный массивы (программа на языке паскаля) 2)составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с датчика случайных чисел

anastasiya2905 anastasiya2905    3   25.05.2019 10:30    5

Ответы
unicorncolever unicorncolever  21.06.2020 12:18
Var a: array [1..5, 1..5] of integer;
    i, m, j: integer;
begin
     for i := 1 to 5 do
         for j := 1 to 5 do
         begin
              a[i, j] := random(50) - 25;
              writeln('[', i, ',', j, '] => ', a[i, j]);
         end;

     for i := 1 to 5 do
         for j := 1 to 5 do
             if (a[i, j] mod 2 = 0) then a[i, j] := 30;

     writeln();

     for i := 1 to 5 do
         for j := 1 to 5 do
              writeln('[', i, ',', j, '] => ', a[i, j]);
end.

Для второго не понял, как решать ._.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика