1. напишите программу для создания трех массивов, каждый из 8 элементов : a, b и c.

2. заполните массив a с клавиатуры.

3. заполните массив b квадратами номеров соответствующих элементов.

4. заполните массив c случайными числами.

5. выведите эти три массива на экран, расположив их элементы в строку.

зайка191111 зайка191111    2   09.01.2020 16:52    5

Ответы
tarasenkosasa tarasenkosasa  05.08.2020 13:54

Объяснение:

Пишу на c++

#include <iostream>

#include <cstdlib>  

using namespace std;

int main(){

int arr[8], brr[8], crr[8];

for(int i = 0;i<8;i++){

 cin >> arr[i];

 brr[i] = i*i;

 crr[i] = rand();

}

for(int i = 0;i<8;i++){

 cout << arr[i] << " ";

}

for(int i = 0;i<8;i++){

 cout << brr[i] << " ";

}

for(int i = 0;i<8;i++){

 cout << crr[i] << " ";

}

}

На паскале:

var a,b,c: array[1..8] of integer;

var i:integer;

begin

for i:=1 to 8 do

begin

readln(a[i]);

b[i]:= i*i;

randomize;

c[i]:=random(0,100000);

end

for i:= 1 to 8 do

write(a[i]);

for i:= 1 to 8 do

write(b[i]);

for i:= 1 to 8 do

write(c[i]);

end.

ПОКАЗАТЬ ОТВЕТЫ

===== PascalABC.NET =====

begin

 var A := ReadArrInteger('Введите 8 целых чисел:', 8);

 A.Println;

 var B := ArrGen(8, i -> i * i, 1);

 B.Println;

 var C := ArrRandom(8, -99, 99);

 C.Println;

end.

Примечание: Если все три массива надо вывести в одну строку, вместо A.Println и B.Println указать A.Print и B.Print


1. напишите программу для создания трех массивов, каждый из 8 элементов : a, b и c.2. заполните масс
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика