1.Напишите программу для решения задачи с использованием линейного массива:

Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру для дней, когда температура поднималась выше нуля градусов. Определите количество таких дней. Гарантируется, что за время наблюдения хотя бы в один из дней температура поднималась выше нуля градусов.
Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.

gulderya68 gulderya68    3   03.05.2020 17:06    3

Ответы
Pidoraser Pidoraser  14.10.2020 06:19

#Python

array = []

plus_days = 0

for x in range(int(input())):

   day = int(input())

   if day > 0:

       array.append(day)

       plus_days += 1

print(plus_days)

print(sum(array) / len(array))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика