1. напишите программу,чтобы найти сумму цифр заданного числа а=23451.
2.Даны три числа а,b,c. Найти наибольшее число.
3.Переведите с двоичной системы в десятичную и напишите программу перевода.
10101011 внизу 2=x внизу 10
(программа Питон)​

allknown allknown    2   12.03.2021 17:00    9

Ответы
лалка136 лалка136  11.04.2021 17:00

1:

s = 0

a = int(input('Введите число: '))

while a>0:

 s += a%10

 a = a//10

print('Сумма цифр равна ', s)

2:

a = int(input('Введите a: '))

b = int(input('Введите b: '))

c = int(input('Введите c: '))

min = a

max = a

if b < min: min = b

if b > max: max = b

if c < min: min = c

if c > max: max = c

print('Минимальное из введённых: ', min)

print('Максимальное из введённых: ', max)

3:

a = input('Введите число в двоичной системе счисления: ')

s = 0

for i in enumerate(a[::-1]):

 s += int(i[1])*2**i[0]

print('В десятичной системе счисления это: ', s)

ответ: 171

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика