1.Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб. 2.Написать программу, которая бы по введенному номеру единицы измерения (1 — килограмм, 2 — миллиграмм, 3 — грамм, 4 — тонна, 5 — центнер) и массе М выдавала соответствующее значение массы в килограммах.
c++

AliceRosen AliceRosen    1   24.06.2021 18:36    16

Ответы
ФёдорХоменко ФёдорХоменко  24.07.2021 18:37

Простейшее задание

Объяснение:

#include <iostream>

#include <functional>

#include <string>

#include <vector>

 

struct converter

{

  std::function<double(double)> function;

  std::string to;

};

 

int main()

{

  std::vector<converter> table =

  {

     {[](double d) { return d; }, "kg"},

     {[](double d) { return d / 1000 / 1000; }, "mg"},

     {[](double d) { return d / 1000; }, "g"},

     {[](double d) { return d * 100; }, "cnt" },

     {[](double d) { return d * 1000; }, "tones" }

  };

  int ind = 0;

  std::cin >> ind;

  ind -= 1;

  if (ind >= 0 && ind < table.size())

  {

     int m = 0;

     std::cin >> m;

     const converter& current = table[ind];

     std::cout << "Result of converting " << m << " " << current.to << " is " << current.function(m) << " kg" << std::endl;

  }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика