1. написать программу вычисления площади кольца, где исходными данными являются радиусы кольца и отверстия. предусмотреть в программе проверку правильности исходных данных (радиус отверстия не может быть больше радиуса кольца). сделать на паскале и можно в документе прикрепить
begin
var r1:=abs(ReadReal('Наружный радиус кольца'));
var r2:=abs(ReadReal('Внутренний радиус кольца'));
if (r1*r2>0) and (r1>r2) then
Writeln('Площадь кольца ',pi*(sqr(r1)-sqr(r2)))
else Writeln('Неверные данные')
end.
Тестовое решение:
Наружный радиус кольца 25
Внутренний радиус кольца 21.8
Площадь кольца 470.484915801607