1. написать программу, решающую уравнение ax=b. предусмотреть все варианты для значений a и b. 2. идет к-ая секунда суток. определить, сколько целых часов и целых минут с начала суток. на экран вывести фразу: «it is … hours … minutes». 3. вводится пятизначное число. найти сумму цифр этого числа. написать программы в паскале.

popopolka111 popopolka111    3   16.03.2019 15:20    2

Ответы
mogilastaaalena mogilastaaalena  25.05.2020 16:53

1.

 

program simple;

var a,b:integer;

begin

 writeln('daite a, b); readln(a,b);

 writeln('x = ', b/a); readln;

end;

 

2.

 

program day;

var h,hours,minutes:longint;

begin

  writeln('daite secundi'); readln(h);

  hour:= h div 3600; minutes:=h mod 36000;

  if (minutes > 60) or (minutes=60) then 

   begin

     hour:=hour+1;

     minutes:=minutes-60;

  end;

  writeln('It is 'hours' hours 'minutes' minutes');

readln;

end;

 

3.

 

program summaChisla;

var s:string; i,sum: longint; c,cod:integer;

begin

  writeln('daite nomer); readln(s);

  for i:=1 to length(s) do

   begin

      val(s[i],c,cod); sum:=sum+c;

   end;

writeln('summa :',sum); readln;

end;

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика