1. Написать программу нахождения суммы большего и меньшего из 3 чисел.
2. Разработать программу для нахождения корней квадратного уравнения.

К каждой программе написать построчно комментарии к выполняемым действиям,
т.е. уточнить, что именно происходит в программе на данном этапе.
var a:integer; {объявление переменной а целочисленного типа}
…..
if t > 10 then… {проверка условия t>10}
и т.д.

veronikkot2016 veronikkot2016    1   03.05.2020 18:45    7

Ответы
leonik9797 leonik9797  14.10.2020 06:21

Первая программа

var a,b,c: integer;

min, max, s: integer;

begin

writeln('Введите числа');

readln(a,b,c);

if (a>b) then max:=a else max:=b;

if (c>max) then max:=c;

if (a<b)then min:=a else min:=b;

if (c<min)then min:=c;

s:=max+min;

writeln('Сумма максимального и минимального числа =', s);

end.

Вторая программа

Она состоит из процедуры и выводит на экран начальное уравнение, корни уравнения и дискриминант.

program sqrturavnenie;

uses crt;

Var a, b, c:Real;

procedure sq(a, b, c:Real);

Var d, x1, x2:Real;

Begin

d:=b*b-4*a*c;

Writeln ('d= ', d) ;

If d>=0 then begin

x1:=(-b+sqrt(d)) /(2*a);

x2:=(-b-sqrt(d))/(2*a);

If x1=x2 then

Writeln ('x1= ', x1:6:2)

else

Writeln ('x1=', x1:6:2, 'x2= ', x2:6:2)

End

Else

Writeln ('Корней нет!');

End;

begin

Clrscr ;

Writeln ('a= ');

Readln (a);

Writeln ('b= ');

Readln (b);

Writeln ('c=') ;

Readln (c);

Writeln (a:6:2,'x*x+ ', b:6:2, 'x+ ', c:6:2);

sq(a, b, c);

Readln

end.

С комментариями будет трудно

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика