1. Написать программу на языке Паскаль (линейный алгоритм)
Найти произведение значений двух переменных и вывести результат на экран.
2. Написать программу на языке Паскаль (разветвляющийся алгоритм)
Ввести два числа. Вычесть из большего меньшее.
3. Написать программу на языке Паскаль (алгоритмы с циклом)
3.1. Вывести на экран 3 раза свое ФИО. Особенность: одинаковые действия выполняются 3 раза.
3.2. Вычислить сумму ряда S = 1+1.5+2+2.5+3+3.5+…+ 20.
3.3. Написать программу ввода неопределённого ряда целых чисел до тех пор, пока не будет введён 9. После ввода 9 программа должна вывести сообщение «Программа заверщена».

shtylenko2002 shtylenko2002    1   15.05.2020 15:50    25

Ответы
sanydrr1 sanydrr1  24.08.2020 17:16

1

var

ch1, ch2: Integer;

begin

readln(ch1, ch2);

WriteLn(ch1*ch2);

end.

2

var

ch1, ch2: Integer;

begin

readln(ch1, ch2);

WriteLn(abs(ch1-ch2));

end.

3.1

var

i:Integer;

begin

for i:=1 to 3 do

WriteLn('ФИО')

end.

3.2

var

ch, sum: real;

begin

sum:=0;

ch :=1;

while ch <= 20 do

begin

sum:= sum +ch;

ch:=ch+0.5;

end;

WriteLn(sum);

end .

3.3

var

ch:LongInt;

begin

ReadLn(ch);

while (ch>9) or (ch<9) do

begin

ReadLn(ch);

end ;

WriteLn('Программа завершена');

end .

как лучший

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика