1) написать программу,которая вводит таблицу квадратов первых 10 чисел. 2)найти все натуральные числа а,b,с, из интервала от 1 до 10 для которых выполняется равенство а^2+b^2=c^2

smasa3450 smasa3450    3   09.08.2019 05:10    4

Ответы
alina067 alina067  04.10.2020 06:37
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication5
{
    class Program
    {
        static void Main(string[] args)
        {
            // 1) Написать программу,которая вводит таблицу квадратов первых 10 чисел.
            for (int i = 1; i <= 10; i++)
            {
                Console.WriteLine(i + "^2=" + Math.Pow(i, 2));
            }

            Console.ReadKey();

            // 2) Найти все натуральные числа а,b,с, из интервала от 1 до 10 для которых выполняется равенство а^2+b^2=c^2

            for (int a = 1; a <= 10; a++)
            {
                for (int b = 1; b <= 10; b++)
                {
                    for (int c = 1; c <= 10; c++)
                    {
                        if (Math.Pow(a, 2) + Math.Pow(b, 2) == Math.Pow(c, 2))
                            Console.WriteLine("a=" + a + "; b=" + b + "; c="+c);
                    }
                }
            }

            Console.ReadKey();
        }
    }
}
ПОКАЗАТЬ ОТВЕТЫ
Лера12435 Лера12435  04.10.2020 06:37
1)
var i:integer;
begin
for i:=1 to 10 do writeln(i,' - ',i*i);
end.

Результат:
1 - 1
2 - 4
3 - 9
4 - 16
5 - 25
6 - 36
7 - 49
8 - 64
9 - 81
10 - 100

2)
var a,b,c:integer;
begin
for a:=1 to 10 do
 for b:=1 to 10 do
  for c:=1 to 10 do
   if a*a+b*b=c*c then writeln(a,' ',b,' ',c);
end.

Результат:
3 4 5
4 3 5
6 8 10
8 6 10
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика