1. написать программу, которая в последовательности чисел ,вычисляет количество чисел заканчивающихся на 5. 2.написать программу, которая в последовательности чисел ,вычисляет сумму чисел кратных 4 и заканчивающихся на 8. 3.написать программу, которая в последовательности чисел ,вычисляет среднее арифметическое четных чисел.​

Pisos1337228 Pisos1337228    3   02.12.2019 17:17    3

Ответы
kamuxa kamuxa  10.10.2020 17:57

1. Количество чисел в последовательности вводится пользователем

var n,i,a,k: integer;

begin

write('Введите количество чисел в последовательности ');

readln(n);

for i := 1 to n do

begin

write('Введите число: ');

readln(a);

if a mod 10 = 5 then k:=k+1

end;

writeln('Количество чисел заканчивающихся на 5 равно ',k)

end.

2. Признак окончания последовательности ввод 0 (цикл while)

var a,s:integer;

begin

write('Введите число: ');

readln(a);

while a<>0 do

begin

if(a mod 4 = 0) and (a mod 10 = 8) then s:=s+a;

write('Введите число: ');

readln(a)

end;

writeln('Сумма чисел кратных 4 и заканчивающихся на 8 равна ',s)

end.

3. Признак окончания последовательности ввод 0 (цикл repeat)

var a,k,s: integer;

begin  

repeat

write('Введите число: ');

readln(a);

if a mod 2 = 0 then

begin

k:=k+1;

s:=s+a

end

until a=0;

writeln;

writeln ('Среднее арифметическое четных чисел равно ',s/k)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика