1)написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)написать программу, которая выводит на экран перевёрнутый текст. 3)написать программу, которая определяет является ли слово палиндромом. 4)написать программу, определяющую какая из букв а илио встречается в тексте первой. хотябы одну ))нужно до

ПоЛиНа201420142014 ПоЛиНа201420142014    3   21.03.2019 01:40    9

Ответы
SтивLan04 SтивLan04  26.05.2020 11:38

1. 

char name[15];                // имя

char famil[20] ;                // фамилия  

Printf("Как Вас зовут?\n") ; printf("Введите свое имя и фамилию,");

printf("-> "); scanf("%s", &name);        //функция scanf читает из буфера клавиатуры символы

scanf("%s", &famil);        //до разделителя - пробел  

printf("Здравствуйте, %s %s!\n", name, famil);   

ПОКАЗАТЬ ОТВЕТЫ
123maladauskas 123maladauskas  26.05.2020 11:38

1)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
 
int main()
{
    char s[20];

    cout << "What is your name: ";
    cin >> s;

    cout << "Hello, " << s << endl;
 
   return 0;
}

 

2)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[100];

    cout << "Enter the string: ";
    cin.getline(s, 100);

    for(int i = strlen(s) - 1; i >= 0; i--)
    {
        cout << s[i];
    }
    cout << endl;
 
   return 0;
}

 

3)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[20];
    bool x = true;

    cout << "Enter the word: ";
    cin.getline(s, 100);

    for(int i = 0, j = strlen(s) - 1; i <= j; i++, j--)
    {
        if(s[i] != s[j])
        {
            x = false;

            break;
        }
    }

    if(x)
    {
        cout << "Palindrome" << endl;
    }
    else
        cout << "Not palindrome" << endl;
 
   return 0;
}

 

4)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;
#include <cstring>
using std::strlen;
 
int main()
{
    char s[100];
    char n;

    cout << "Enter the string: ";
    cin.getline(s, 100);

    for(int i = 0; i < strlen(s); i++)
    {
        if(s[i] == 'a')
        {
            n = 'a';

            break;
        }
        else if(s[i] == 'o')
        {
            n = 'o';

            break;
        }
    }

    if(n == 'a')
    {
        cout << "\nThe first letter of A" << endl;
    }
    else if(n == 'o')
    {
        cout << "\nThe first letter of O" << endl;
    }
    else
        cout << "These letters are not available" << endl;
 
   return 0;
}


1)написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)написать программу
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика