1.написать программу, которая проверяет, образуют ли элементы введенного с клавиатуры массива неубывающую последовательность. 2.вставить число а перед всеми элементами, большими а, а число в - после всех элементов, меньших его. 3.дана матрица ф(6х7), заполненный случайным образом. заменить максимальный элемент каждой строки на противоположный по знаку. 4. дан двумерный массив. найти сумму элементов его главной диагонали и поизведение элементов побочной диагонали. результат занести в одномерный массив. , , нужно! хотя бы некоторые решите. второй день не могу сделать! тема одномерных и двумерных массивов.

Xilolahonabdullaeva Xilolahonabdullaeva    3   03.06.2019 16:40    3

Ответы
gamerXpro gamerXpro  03.07.2020 22:51
                                           НАПИСАНО НА ПАСКАЛЕ!
2)

program fofgogjoj;
const nmax=100;
var
m:array[1..nmax] of integer;    
n,i,j,k:byte;    
a,b,x:integer;
begin
randomize;
repeat Write('Размер массива до ',nmax div 3,' n=');
readln(n);
until n in [1..nmax div 3];
Writeln('Исходный массив:');
for i:=1 to n do  
begin
m[i]:=random(50);  
Write(m[i],' ');  
end;
Writeln;
Writeln;
Write('Введите число для вставки перед a=');
Readln(a);
i:=1;
k:=0;
while i<=n do  
begin
if m[i]>a then    
begin    
n:=n+1;    
k:=1;    
for j:=n downto i+1 do    
m[j]:=m[j-1];    
m[i]:=a;    
i:=i+2;    end  
else i:=i+1;  
end;
if k=0 then
Writeln('Элементов больше ',a,' нет')
else  
begin  
Writeln('Массив после вставки числа ',a,' перед большими ',a);  
for i:=1 to n do  
Write(m[i],' ');  
Writeln;  
Writeln;  
Write('Введите число для вставки после b=');  
Readln(b);  
i:=1;k:=0;  
while i<=n do  
if m[i]<b then    
begin    
n:=n+1;    
k:=1;    
for j:=n downto i+2 do    
m[j]:=m[j-1];    
m[i+1]:=b;    
i:=i+2;    end  
else
i:=i+1;  
if k=0 then
Writeln('Элементов меньше ',b,' нет')  
else    
begin    
Writeln('Массив после вставки числа ',b,' после меньших ',b);    
for i:=1 to n do    
Write(m[i],' ');    
end;  
end;
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика