1 написать программу которая проверяет на кратность 5 произведение цифр двузначного числа вводимого с клавиатуры в ответе написать да или нет. 2 написать программу которая удваивает наибольшую цифру двузначного целого числа результат на экран. 3 написать программу которая утраивает четные цифры двузначного числа результат на экран.

dikozzz dikozzz    3   24.08.2019 04:50    3

Ответы
Nastya251551 Nastya251551  31.08.2020 20:54
1.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1*a2 mod 5 = 0
 then writeln('Да') else writeln('Нет');
end.

Пример:
a = 52
Да

2.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1>a2
 then writeln('2*',a1,' = ',2*a1) else writeln('2*',a2,' = ',2*a2);
end.

Пример:
a = 93
2*9 = 18

3.
var a,a1,a2:integer;
begin
write('a = ');
readln(a);
a1:=a div 10;
a2:=a mod 10;
if a1 mod 2 = 0 then writeln('3*',a1,' = ',3*a1);
if a2 mod 2 = 0 then writeln('3*',a2,' = ',3*a2);
end.

Пример:
a = 45
3*4 = 12
ПОКАЗАТЬ ОТВЕТЫ
musukaev699 musukaev699  31.08.2020 20:54
// PascalABC.NET 3.2, сборка 1387 от 20.02.2017
// Внимание! Если программа не работает, обновите версию!

№1
begin
  var n:=ReadInteger('Введите двухзначное целое:');
  (var p,var q):=(n div 10,n mod 10);
  if (p*q) mod 5=0 then Writeln('Да')
  else Writeln('Нет')
end.

№2
begin
  var n:=ReadInteger('Введите двухзначное целое:');
  (var p,var q):=(n div 10,n mod 10);
  Writeln(Max(p,q)*2)
end.

№3
begin
  var n:=ReadInteger('Введите двухзначное целое:');
  (var p,var q):=(n div 10,n mod 10);
  if p.IsEven then p*=3;
  if q.IsEven then q*=3;
  Println(p,q)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика