1) написать программу, которая предлагает пользователю пройти тест на знание таблицы умножения. для прохождения теста, пользователю нужно выбрать число, умножение на которое будет проверять компьютер и количество вопросов по завершении теста компьютер должен выдать результат в процентном соотношении.

21Oleg12 21Oleg12    1   28.09.2019 16:10    4

Ответы
00lom00 00lom00  09.10.2020 00:54

#include <iostream>

#include <cstdlib>

#include <ctime>


int main()

{

   std::srand(std::time(NULL));


   unsigned short int

       number,

       value,

       _value,

       correct = 0;

   std::cout << "Введите число, умножение на которое будет происходить, и кол-во вопросов: ";

   std::cin >> number >> value;


   _value = value;

   while(_value > 0)

   {

       unsigned int

           _number,

           tmp = 1 + std::rand() % 10;

       std::cout << number << " * " << tmp << " = ";

       std::cin >> _number;

       if(_number == tmp * number)

       {

           std::cout << "Верно." << std::endl;

           correct++;

       }

       _value--;

   }

   std::cout << "Процентное соотношение: " << 100 * (static_cast<float>(correct) / value) << "%."

       << std::endl;

}


1) написать программу, которая предлагает пользователю пройти тест на знание таблицы умножения. для
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика