1. написать программу, которая подсчитывает количество, сумму и среднее арифметическое положительных чисел последовательности. размер последовательности определяет сам пользователь программы. 2. написать программу, которая подсчитывает сумму и количество чисел последовательности, делящихся на 8 без остатка. размер последовательности определяет сам пользователь программы. принять, что последовательность состоит только из целых положительных чисел.

Маша20041124 Маша20041124    1   18.09.2019 09:40    5

Ответы
Ира5563 Ира5563  07.10.2020 23:44
Varsumma,Shet,a,b,c:integer;SAP:real;L:array [1..999] of integer;beginWrite('Сколько чисел? ');read(a);for b:=1 to a do beginwrite('Введите число ' );read(c);if (c>0) then begin Shet:=Shet+1; summa:=summa+c; SAP:=SAP+c; end;end;SAP:=SAP/Shet;Writeln(' Сумма = ',summa,' Сред = ',SAP:5:5,' Количество = ',Shet);read(a);end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика