1. написать программу которая ищет n! (цикл while)2. написать программу, которая находит число р = (1-1/2)(1-1/3)**(1-1/n). n вводится с клавиатуры. (цикл for)

kise1970 kise1970    3   14.04.2019 20:42    20

Ответы
romankostin2006 romankostin2006  29.05.2020 12:06

Объяснение:

1.

var

 k:integer;

 p:integer;

 n:integer;

begin

 readln(n);

 

 p:=1;

 k:=1;

 

 while (k <= n) do begin

   p:=p*k;

   k:=k+1;

 end;

 

 writeln(p);

 

end.

2.

var

 k:integer;

 p:real;

 n:integer;

begin

 readln(n);

 

 p:=1;

 

 for k:=2 to n do begin

   p:=p*(1 - (1/k));

 end;

 

 writeln(p);

 

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика