1. Написать программу, которая формирует случайным образом массив из N целых чисел, лежащих в диапазоне от 1 до 5, после чего на экран выводится сам массив и номера элементов, совпадающих с первым элементом. Протестировать программу на трёх различных тестах.

2. Написать программу, которая вводит массив из N целых чисел и выводит на экран элементы, кратные числу K.

3. Написать программу, которая вводит массив из N вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число Z, этим числом. Вывести на экран полученный массив и количе-ство замен.

Мы не изучали константы, поэтому можно обойтись без них?

Bananchik26 Bananchik26    3   13.04.2020 20:46    12

Ответы
макс3113 макс3113  13.10.2020 04:49

1)

#include <iostream>

#include <cmath>

#include <vector>

#include <algorithm>

#include <set>

using namespace std;

signed main() {

   srand(time(NULL));

   int n;

   cin >> n;

   int a[n];

   for(int i = 0; i < n; i++)

       a[i] = rand() % 5 + 1;

  vector<int> ans;

   for(int i = 0; i < n; i++)

   {

       cout << a[i] << " ";

       if(a[i] == a[0])

           ans.push_back(i);

   }

   cout << "\n";

   for(auto i: ans)

       cout << i << " ";

}

2)

#include <iostream>

#include <cmath>

#include <vector>

#include <algorithm>

#include <set>

using namespace std;

signed main() {

   int n,k;

   cin >> n >> k;

   int a[n];

   vector<int> ans;

   for(int i = 0; i < n; i++)

   {

       cin >> a[i];

       if(a[i] % k == 0)

           ans.push_back(a[i]);

   }

   for(auto i: ans)

       cout << i << " ";

}

3)

#include <iostream>

#include <cmath>

#include <vector>

#include <algorithm>

#include <set>

using namespace std;

signed main() {

   int n,z;

   cin >> n >> z;

   int a[n];

   for(int i = 0; i < n; i++)

   {

       cin >> a[i];

       a[i] = min(a[i],z);

   }

   for(auto i: a)

       cout << i << " ";

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика