1. написать программу для решения : точки на плоскости заданы своими координатами. определить какая из них находится ближе к началу координат.

aadfgjrv aadfgjrv    2   29.05.2019 14:50    6

Ответы
kiry42rus kiry42rus  01.10.2020 14:11
Uses crt;
var n,minind,i:integer;
min,x,y:real;
begin
writeln('Введите количество точек: ');
read(n);
writeln('Вводите по очереди координаты x и y точек.');
read(x,y);
min:=sqr(x)+sqr(y);
minind:=1;
for i:=2 to n do
begin
read(x,y);
if sqr(x)+sqr(y)<min then
begin
min:=sqr(x)+sqr(y);
minind:=i;
end;
end;
writeln('Точка под номером ',minind,'.');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика