1.массив состоит из чисел 7, 8 и 9. переставить элементы массива таким образом, чтобы сначала стояли все числа 8, потом -7, а в конце - 9. 2. написать программу, определяющую возможность представления заданного натурального числа м в виде суммы двух квадратов натуральных чисел.

TatarskayaGreckha TatarskayaGreckha    2   09.07.2019 11:20    2

Ответы
Food7983427 Food7983427  07.09.2020 08:20
1)var ar:array[1..10] of integer;
ar2:array[1..10] of integer;
i,k,m:integer;
begin;
randomize;
writeln('First array');
for i:=1 to 10 do
begin;
ar[i]:=random(7,9);
write(ar[i]:4);
end;
m:=0;
writeln;
for i:=1 to 10 do
if ar[i]=8 then
begin;
inc(m);
ar2[m]:=8;
end;
for i:=1 to 10 do
if ar[i]=7 then
begin;
inc(m);
ar2[m]:=7;
end;
for i:=1 to 10 do
if ar[i]=9 then
begin;
inc(m);
ar2[m]:=9;
end;
writeln('Final array');
for i:=1 to 10 do
begin;
ar[i]:=ar2[i];
write(ar[i]:4);
end;
end.
2)var a,b,m,i,j,c:int64;
begin;
readln(m);
for i:=1 to m do
begin;
for j:=1 to m do
if sqr(i)+sqr(j)=m then
begin;
writeln(i,'^2+',j,'^2=',m);
c:=1;
end;
end;
if c<>1 then
writeln('Невозможно');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика