1.используя функции символьных переменных, написать программу, которая из текста «я хорошая вычислительная машина», получила бы текст «я хорошая машина». 2.используя функции символьных переменных, написать программу получения из слова железнодорожник слов донор, жезл, колено, крокодил.

maksimprikhodko maksimprikhodko    1   10.09.2019 09:30    1

Ответы
WolfHunter1 WolfHunter1  07.10.2020 05:02
Эмм.. Pascal:

var
a, b, c:String;
begin
a := 'Я очень хорошая вычислительная машина';
b := 'Я хороший робот';
writeln('Введите текст ', a, ' и получите текст', b);
readln(c);
if a = c then
begin
writeln(b);
end;
end.

ответ 2:
var
b: array [1..4] of String[9] = ('ДОНОР', 'ЖЕЗЛ', 'КОЛЕНО', 'КРОКОДИЛ');
a, c:String;
i:Integer;
begin
a := 'ЖЕЛЕЗНОДОРОЖНИК';
writeln('Введите текст ', a, ' и получите слова');
for i:= 1 to 4 do
begin
writeln(b[i]);
end;
readln(c);
if a = c then
begin
for i:= 1 to 4 do
begin
writeln(b[i]);
end;
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика