1. даны два ненулевых числа а и b. напишите программу для нахождения суммы, разности, произведения и частного. 2. напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b. 3. ввести трехзначное число a. напишите программу которая поменяет крайние цифры числа местами.

owl42 owl42    1   22.08.2019 08:40    9

Ответы
farhinura10009 farhinura10009  05.10.2020 12:10
1)
Program n1;
var a,b: real;
begin
readln(a,b);
writeln('разность: ',a-b);
writeln('произведение: ',a*b);
writeln('сумма: ',a+b);
writeln('частное: ',a/b);
end.
2)
Program n2;
var a,b,c: real;
begin
readln(a,b);
c:=sqrt(a*a+b*b);
writeln('площадь: ',0.5*a*b);
writeln('периметр: ',a+b+c);
end.
3)
Program n3;
var d1,d2,d3,a: integer;
begin
write('введите число: ');
readln(a);
d1:= a div 100;
d2:=a div 10 mod 10;
d3:=a mod 10;
writeln(d3,d2,d1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика