1) даны два числа а и b. написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. 2) дано целое число. написать программу, которая заменяет его на 0, если число отрицательное, и выводит его без изменений, противном случае. 3) дано целое число n. написать программу увеличивающую его на 10, если число больше 0.

MoriYuka MoriYuka    3   11.06.2019 20:10    7

Ответы
annkhanenko23 annkhanenko23  09.07.2020 16:57
Задача 1
var
a,b:Integer;
Begin
 Read(a,b);
 if (a>b) then Writeln(b)
  else if (a<b) then Writeln(a)
  else Writeln('Числа равны');
end.

Задача 2
var
n:Integer;
Begin
 Read(n);
 if (n<0) then Writeln(0)
  else Writeln(n);
end.

3адача 3.
var
n:Integer;
Begin
 Read(n);
 if (n>0) then Writeln(n+10)
  else Writeln(n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика