1. дан фрагмент программы, определяющий количество неотрицательных элементов массива a[1..10]. восстановите пропущенное условие.
k: =10;
i: =1;
while i< =10 do
begin
if then k: =k – 1;
i: =i+1
end;
write (p)
a[i]> 0
a[i]> 0
a[i]< =0
a[i]< 0
2.задан одномерный массив а, содержащий n элементов. укажите, что будет определено в результате работы следующего фрагмента программы:
k: =0;
for i: =1 to n do
if a[i]> =0 then k: =k+1
количество положительных элементов массива
максимальный элемент массива
количество неотрицательных элементов массива
сумма положительных элементов массива

3. что такое массив?
это структурированный тип данных, состоящий из элементов разных типов
это совокупность данных, объединенных под одним именем
это структурированный тип данных, состоящий из элементов одного типа, по номеру и объединенных под одним именем
это простой тип данных, состоящий из одного элемента
4. задан одномерный массив а, содержащий n элементов. значения всех элементов массива различны. укажите, что будет определено в результате работы следующего фрагмента программы:
m: =a[1];
for i: =1 to n do
if a[i]< =a[1] then m: =a[i]
значение максимального элемента массива
индекс максимального элемента массива
значение минимального элемента массива
индекс минимального элемента массива
5. дан одномерный массив.
-125 200 10 0 43 11

чему равно значение элемента массива с индексом 3.
6. выберите правильное описание массива а, состоящего из нескольких переменных вещественного типа
a : array [1..25] of real
a : array [1..25] of integer
a : [1..25] of real
a : array [1..25] of byte
7. var a: array [1..59] of integer;
при выполнении этого оператора в памяти компьютера будет выделено … ячеек целого типа.
50
58
59
60
8. каким ввода элементов массива а лучше воспользоваться, если значения элементов массива равны своим удвоенным индексам?
с оператора присваивания по формуле a[i]: =2* a[i]
с оператора присваивания по формуле a[i]: =2*i
с оператора присваивания случайными числами
любым из предложенных вариантов
9. выберите правильные варианты вывода элементов массива на печать в столбик. (2 ответа)
for i: =1 to n do writeln (a[i])
for i: =1 to n do writeln (`a`, i, `=`, a[i])
for i: =1 to n do write (a[i], ` ` )
for i: =1 to n do writeln ( i, `]=`)
10. какой оператор необходимо вставить вместо многоточия в следующий фрагмент программы на языке паскаль, чтобы верно решалась нахождения суммы элементов массива а, содержащего n элементов?

for i: =1 to n do s: =s+a[i]
s: =a[1]
s: =a[n]
s: =1
s: =0

azamatmarahimov azamatmarahimov    2   16.10.2019 20:50    4417

Другие вопросы по теме Информатика