1.cоставить программу,которая заполняет квадратную матрицу 9 х 9. 1 1 1 1 2 2 2 3 3 3 9 9 9 2.составить программу решения поставленной . в прямоугольной матрице отрицательные числа заменить им противоположными.

wami56 wami56    3   30.08.2019 04:10    2

Ответы
Xopccc13377 Xopccc13377  06.10.2020 04:21
// PascalABC.NET 3.2, сборка 1425 от 22.04.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=MatrGen(9,9,(i,j)->i+1); a.Println(2);
end.

Результат
 1 1 1 1 1 1 1 1 1
 2 2 2 2 2 2 2 2 2
 3 3 3 3 3 3 3 3 3
 4 4 4 4 4 4 4 4 4
 5 5 5 5 5 5 5 5 5
 6 6 6 6 6 6 6 6 6
 7 7 7 7 7 7 7 7 7
 8 8 8 8 8 8 8 8 8
 9 9 9 9 9 9 9 9 9

begin
  var n:=ReadInteger('Количество строк в матрице:');
  var m:=ReadInteger('Количество столбцов в матрице:');
  Writeln('*** Исходная матрица [',n,',',m,'] ***');
  var a:=MatrRandom(n,m,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  Writeln('*** Результат [',n,',',m,'] ***');
  a.Fill((i,j)->Abs(a[i,j])); a.Println(4)
end.

Пример
Количество строк в матрице: 4
Количество столбцов в матрице: 7
*** Исходная матрица [4,7] ***
  10  42   3  83 -65  43  65
 -52 -40  55  75 -27  53 -47
  17  88  93  32  35  41 -76
  70  13   6   2   9 -22 -55

*** Результат [4,7] ***
  10  42   3  83  65  43  65
  52  40  55  75  27  53  47
  17  88  93  32  35  41  76
  70  13   6   2   9  22  55
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика