1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read (с,b); If (с>b) or (b mod 2=0) then а:=b+2 else а:=с div 3; Writeln(a); End.
2)Напишите программу решения задачи. Дано число n. Если оно не кратно 3 или равно числу b, то вывести число n, увеличенное на 2, иначе найти 18% от числа b.
3)Напишите программу решения задачи. Дано двузначное число а. Если последняя цифра этого числа больше первой, то вывести число а, уменьшенное на 100.

Ilmaz2p Ilmaz2p    2   22.04.2020 09:26    10

Ответы
Мариша741 Мариша741  13.10.2020 15:53

Задание 2, 3 во вложении

Объяснение:

Задание 1.

Сначала вводятся переменные b и с через пробел.

Мы вводим сначала с, оно равно 205, и затем b, оно равно 204.

затем идет условие.

Если с>b или b mod 2=0

Если 205>204 или

b mod 2=0 - это означает, число b кратно 2, то есть при делении на 2 оно должно дать 0.

В нашем случае 204/2=102 , то есть число 204 кратно 2, оно поделилось на него без остатка.

Первое и второе условие сработало, а значит выполняется следующее:

a:=b+2;

То есть в переменной а мы к b прибавляем 2. И у нас выходит:

a:=204+2=206

Условие иначе у нас не работает, поэтому выводим:

Writeln(a);

Программа выведет число а

206.


1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика