tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Вывести квадраты чисел от 1
Вывести квадраты чисел от 1 до n. в паскале написать программу (не используя for)
xiu99
2 20.09.2019 22:40
1
Ответы
armen6204
08.10.2020 05:40
1)
// PascalABC.NET 3.3
begin
var n:=ReadInteger('n =');
Range(1,n).Select(i->i*i).Println;
end.
Пример:
n = 5
1 4 9 16 25
2)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
while (i<n) do
begin
i:=i+1;
write(i*i,' ');
end;
end.
3)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
repeat
i:=i+1;
write(i*i,' ');
until i=n;
end.
Пример:
N = 5
1 4 9 16 25
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
F228o228X
18.11.2020 18:21
В папке находится 6 файлов, имена которых перечислены в первом столбце таблицы Определите, какие из них будут отобраны по каждой из четырех масок:...
ЗаучкаГрейнджер
18.11.2020 18:21
Заполните пустые клетки таблицы, вычислив время звучания записи (объем файла приведен без учета сжатия): распишите все подробно, с шагами решения и все такое...
Роман768
18.11.2020 18:21
Чим обумовлена потреба в типізації даних в ЕT?...
olhkasianchuk
12.03.2021 16:30
За що відповідає метод Show ?...
yuriymakarov1
23.02.2020 17:47
Какова иерархия применения стилей к абзацу?...
6ВинишкоТян9
23.02.2020 17:48
2.Создай презентацию из 4-5 слайдов на тему «Звукиокружающей среды». Добавь к каждому слайдусоответствующие звуки. Что ты знаешь озвуках? Какоезначение имеют звуки?...
Катя388891
23.02.2020 17:52
Этапы, которых стоит придерживаться при разработке любых баз данных:Тестирование ввода презентаций в таблицы.Выяснение задач, для которых будет использоваться разрабатываемая...
vlad2044
27.04.2020 08:23
1. Запишите первую строку бесконечного цикла на языке...
demoooon24
02.02.2021 22:53
Надо написать программу паскаль,которая а)Просит ввести количество людей,затем просит ввести их массу и выводит на экран их общюю массу б)В этой же программе надо...
xammatovrunar
03.10.2019 05:20
Вопрос на 40 ! кто сможет перевести текст с на кабардинский я тебя люблю!...
Популярные вопросы
5. Определите, принадлежит ли графику прямой пропорцио- нальной...
1
Найдите область определения функции y=(log3x-log2x)-0.5...
1
1. де залишала Катря малого Тараса 2.на яку роботу треба було йти...
3
Найдите все квадратные трехчлены f(x) такие, что f(x + 1) ≡ f(-x)....
3
3. ДРЕВНЯЯ ИНДИЯ Выбранная тема: (укажите букву в перечне).Прочитайте...
2
Выпішыце па 5 сказаў з пабочнымі словамі, і па 5 сказаў са звароткамі...
2
12. Найдите наименьшее значениефункции f(x) = 2х2 + 8x...
2
Тело движется вдоль координатной оси. Его координата определяется...
3
Отметьте биологические функции, которые не выполняют паразиты:...
1
СОР ПО БИОЛОГИИ 2 за 3 четверть движения . Биофизики составьте...
3
// PascalABC.NET 3.3
begin
var n:=ReadInteger('n =');
Range(1,n).Select(i->i*i).Println;
end.
Пример:
n = 5
1 4 9 16 25
2)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
while (i<n) do
begin
i:=i+1;
write(i*i,' ');
end;
end.
3)
var n,i: integer;
begin
write('N = ');
readln(n);
i:=0;
repeat
i:=i+1;
write(i*i,' ');
until i=n;
end.
Пример:
N = 5
1 4 9 16 25