Надо написать программу паскаль,которая
а)Просит ввести количество людей,затем просит ввести их массу и выводит на экран их общюю массу
б)В этой же программе надо добавить их среднюю массу.
в) В этой же программе надо чтоб программа выводила на экран информацию,могут ли люди ехать в лифте чья грузоподъёмность 300 кг
даю.

demoooon24 demoooon24    2   02.02.2021 22:53    2

Ответы
Gendalf1875 Gendalf1875  04.03.2021 22:55

var n, k, i:integer;

m:real;

begin

   readln(n);

   

   for i:=1 to n do

       begin

           readln(k);

           m := m + k;

       end;

   

   writeln('Общая масса: ', m);

   writeln('Средняя масса: ', m/n);

   

   if (m < 300) then

       begin

           writeln('Люди могут ехать!');

       end

   else

       writeln('Ехать нельзя!');

end.

Объяснение:

б)В этой же программе надо добавить их среднюю массу.

Не совсем понял куда добавить, поэтому вывел.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика