Составьте программу в паскале: вычислить сумм всех нечётных чисел в интервале от 1 до 2к-1. заранее огромное

kapov2017p0aak6 kapov2017p0aak6    3   19.08.2019 20:20    0

Ответы
СоНя2080 СоНя2080  26.08.2020 07:08
// PascalABC.NET 3.2, сборка 1377 от 19.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('k=');
  Writeln('s=',Range(1,2*k-1,2).Sum)
end.

Пример
k= 4
s=16
ПОКАЗАТЬ ОТВЕТЫ
ZABENOK123 ZABENOK123  26.08.2020 07:08
Var
    k: integer; s: real;
begin
    readln(k);
    s := ((1+(2*k-1))/2)*(((2*k-1)-1)/2+1);
    writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика