Составьте программу,по которой вводится произвольное слово.выбрать число повторов.вывести число на экран лесенкой(со сдвигом вправо).без использования вложенного цикла.

OLYA332321 OLYA332321    1   24.08.2019 14:50    0

Ответы
nagibala09Никичан nagibala09Никичан  05.10.2020 16:49
1)
var s:string; i:integer;
begin
write('Слово: ');
readln(s);
for i:=1 to length(s) do
 writeln(' ':i,s[i]);
end.

Пример:
Слово: лесенка
 л
  е
   с
    е
     н
      к
       а

2)
var s:string; n,i:integer;
begin
write('Слово: ');
readln(s);
write('n = ');
readln(n);
for i:=0 to n-1 do
 writeln('':i*length(s),s);
end.

Пример:
Слово: лесенка
n = 4
лесенка
       лесенка
              лесенка
                     лесенка
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика