Составьте программу, на языке (8 класс) , : определить правильность даты, введенной с клавиатуры (число — от 1 до 31, месяц —от 1 до 12). если введены некорректные данные, то сообщить об этом.

olyaperminova olyaperminova    2   08.10.2019 03:10    57

Ответы
mtv1007 mtv1007  10.10.2020 03:11

var

 Ch, Mes, MaxCh: Integer;

begin

 Write ('Введите число (1-31):');

 ReadLn (Ch);

 if (Ch < 1) or (Ch > 31) then begin

   WriteLn ('Введено некорректное число');

   Exit;

 end;

 Write ('Введите месяц (1-12): ');

 ReadLn (Mes);

 if (Mes < 1) or (Mes > 12) then begin

   WriteLn ('Введен некорректный месяц');

   Exit;

 end;

 case Mes of

 1, 3, 5, 7, 8, 10, 12: MaxCh := 31;

 4, 6, 9, 11: MaxCh := 30;

 2: MaxCh := 28;

 end;

 if Ch <= MaxCh then

   WriteLn ('Дата правильная')

 else

   WriteLn ('Дата неправильная!');

end.

// в программе не учитывается то, что в високосном году февраль имеет 29 дней

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика