ПАСКАЛЬ
Написать программу
Задачи на строки
Даны две произвольные строчки. Совпадают ли они побуквенно?

лерапуся лерапуся    2   22.02.2020 23:12    2

Ответы
Rdamir2008 Rdamir2008  11.10.2020 11:24

program sovpadenie_strok;

uses crt;

var

s1,s2:string;

i:integer;

f:boolean;

begin

read(s1);

read(s2);

if (length(s1)=length(s2))then

begin

i:=1;

f:=false;

while(i<length(s1))and(f=false)

do

begin

if s1[i]<>s2[i] then f:=true;

i:=i+1

end;

if f=true then

write('Строки побуквенно не совпадают')

else

write('Строки побуквенно совпадают')

end

else

write('Строки разной длины')

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика